ESP+ - Performance Issue

Incident Report for ASI

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 00:32 UTC

Update

Hello,
Our internal teams are still working to identify the cause of this issue.
We will send another message as soon as we are able to verify that the issue is resolved.
Posted Oct 29, 2025 - 16:28 UTC

Investigating

Hello,
We are currently experiencing performance issues that are impacting our systems. Our internal teams are working diligently to resolve this. In the meantime, you may experience some temporary service interruptions when using ESP+.
We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve these issues.
Please check back for additional updates.
Posted Oct 29, 2025 - 16:01 UTC
This incident affected: API (Product Details, Product Search), ESP+ (Product Search, Product Details, Websites), and ESP Web, ESP Online.